Forum rules: Do not post bugs or feature requests here! Report bugs to our Issue Tracker and suggestions to Suggest a Feature.

This site is not for solicitation of services or 'purchasing' development. Please do not post requesting side mods/plugins and so on. Your thread will be removed, and you will receive a warning.
By MilesTanin
#186623 Some friends and I have been working on getting a server for us to play around on going. There's apparently a bit of a problem with our setup, though, and if anyone could point us in the right direction that would be great.

The mod seems to be running just fine, we can get into the game. However, upon using certain commands we run into issues. We have the Pixelmon Extras and Gym Wars 2 sidemods installed, and they're the ones that seem to be where most of the issues are.

I'll start with Gym Wars 2, since that is probably just a syntax error. The wiki page gives the command to create a gym as "/creategym <Gym name> <type> <level cap> <Badge> [order]." However, when I type "/creategym BurnyBurns fire 50 HeatBadge 1" as a test I get "That is an invalid type" in response. I'm not quite sure what I'm doing wrong. EDIT: Solved this one with a little more fooling around... have to capitalize the types. But the next issue still stands and was more of a problem to begin with ;-;

With Pixelmon Extras, though, it isn't just a syntax error. A good number of the commands work with no problems, but it seems any that must access a player's party (chiefly /pokeedit) doesn't work. In-game, I get the message "An unknown error occurred while attempting to perform this command."
I checked the console and found this:
Code: Select all14.09 02:51:23 [Server] Server thread/WARN Couldn't process command: 'pokeedit [PLAYERNAME REDACTED] 1 s'
14.09 02:51:23 [Server] INFO java.lang.NoSuchFieldError: PokeballManager
14.09 02:51:23 [Server] INFO at com.pixelextras.commands.PokeEdit.func_71515_b( ~[PokeEdit.class:?]
14.09 02:51:23 [Server] INFO at net.minecraft.command.CommandHandler.func_175786_a( [j.class:?]
14.09 02:51:23 [Server] INFO at net.minecraft.command.CommandHandler.func_71556_a( [j.class:?]
14.09 02:51:23 [Server] INFO at [lm.class:?]
14.09 02:51:23 [Server] INFO at [lm.class:?]
14.09 02:51:23 [Server] INFO at [ie.class:?]
14.09 02:51:23 [Server] INFO at [ie.class:?]
14.09 02:51:23 [Server] INFO at$ [fh$1.class:?]
14.09 02:51:23 [Server] INFO at java.util.concurrent.Executors$ [?:1.8.0_101]
14.09 02:51:23 [Server] INFO at [?:1.8.0_101]
14.09 02:51:23 [Server] INFO at net.minecraft.util.Util.func_181617_a(SourceFile:44) [g.class:?]
14.09 02:51:23 [Server] INFO at net.minecraft.server.MinecraftServer.func_71190_q( [MinecraftServer.class:?]
14.09 02:51:23 [Server] INFO at net.minecraft.server.dedicated.DedicatedServer.func_71190_q( [ko.class:?]
14.09 02:51:23 [Server] INFO at net.minecraft.server.MinecraftServer.func_71217_p( [MinecraftServer.class:?]
14.09 02:51:23 [Server] INFO at [MinecraftServer.class:?]
14.09 02:51:23 [Server] INFO at [?:1.8.0_101]

That second line about the Pokeball Manager is what caught my eye. When we were first deciding what version to run, we tried 4.3.0 Beta 8 and had similar issues with some features. They stated directly in game that the issues were because "Pokeball Manager could not be found." Google had nothing to say on the matter, so we decided to downgrade a bit (not a big deal to us, and we didn't want to deal with jumping through holes for a beta; seems it wasn't the beta's fault though).

Google has nothing enlightening in either department, and neither do the wiki pages of the respective sidemods. Please help?