Forum rules: Do not post bugs or feature requests here! Report bugs to our Issue Tracker and suggestions to Suggest a Feature.

This site is not for solicitation of services or 'purchasing' development. Please do not post requesting side mods/plugins and so on. Your thread will be removed, and you will receive a warning.
By Ganman3
#162814 I've been waiting about a week on my last post (I've been trying to figure it out a month), and I don't think this forum has the answers I need to get my database working. I don't think my server support can help me either.

Could you recommend another forum? I'm still in the early phases of designing my server, and I'm going to need to use database editing to make it possible, but it hasn't been working for me at all.

By Ganman3
#162819 Okay. Thank you. I appreciate your responding. Good luck with your coding.

And I hope so. I might just need to take a break and get my head together. It has been awhile, and it's been a little frustrating. I feel like there's got to be a simple answer, but I've looked at it from all angles.
User avatar
By Jay113355
#162882 Whats wrong?

I looked at your other post. not too sure what your trying to do. but the errors you provided say that your missing the MySQL Driver

19.10 13:36:01 [Server] Server thread/INFO [STDERR]: java.lang.ClassNotFoundException: com.mysql.jdbc.Driver
19.10 13:36:01 [Server] Server thread/INFO [STDERR]: Caused by: java.lang.NullPointerException
19.10 13:36:01 [Server] Server thread/INFO [STDERR]: java.sql.SQLException: No suitable driver found for jdbc:mysql://[ip]:3306/db_8694?user=db_8694&password=[password]

Which is a bit odd considering pixelmon packs the driver in to its mod's jar.

One thing to try doing is downloading the driver jar here: and put it in the mods folder. (fml will complain on startup but nothings wrong)
By Ganman3
#162929 I'm honestly just trying to use the database. I'd like to edit it to configure spawning, since I want to build a world, and part of that depends on choosing what goes where (I'm using biomes for now, but might move up to modding something when I'm ready).

I run the server through an external host for now. I'll move up to hosting it myself when I have a more stable job and can afford it, but for now, this is best.

I did add it to the mods folder in the server directory. No such luck. I get the same null pointer and Class not found exception.

How would I add it to my server run command as a library? I'm still fairly new to Java, and I am doing this remotely, but I do have access to the console and FTP.
By Ganman3
#163801 All right. I talked to my support, repeatedly, using the web hosting service I was using, and they were less than helpful. They said what you said- it must have installed without the proper SQL information- and they told me a clean install should work, or that maybe I could fix it if I updated. After talking with them repeatedly about how to bypass the Multicraft preset (It won't easily let you update to a newer version- it's not simply dropping a new universal jar somewhere, since it uploads the server only with the preset, and when it doesn't find the version you've selected from its drop-down list, it freaks out) it became clear that they weren't going to be very helpful to me.

I changed to another web hosting service at a comparable price, and the service seems a little better, but they're telling me anything related to SQL needs to be managed by me "on my end". I might get a refund.

They installed the latest version of Pixelmon, and I have the same problem, even in 4.1.0. I still get the same errors.

Is there a different jar for Pixelmon servers and client-side Pixelmon, other than the universal? I see a Pixelmon jar that they're installing that isn't universal in the main folder (not the mods folder), and I was wondering where they got that, how that was created, and if that could be the culprit.

Is it possible that it isn't a library error, and I have been typing the config wrong? I only saw one example of it online (Everybody else uses H2, not SQL), and my previous service told me I was typing it right, but they weren't terribly helpful.