Forum rules: Do not post bugs or feature requests here! Report bugs to our Issue Tracker and suggestions to Suggest a Feature.

This site is not for solicitation of services or 'purchasing' development. Please do not post requesting side mods/plugins and so on. Your thread will be removed, and you will receive a warning.

User avatar
By JamieS1211
#147555 Try going into settings in the launcher and change the variables in the java arguments to the desired memory. For example this is what I have

"-XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx1024m -XX:MaxPermSize=128m"
By ghosthawk78
#147563 C:\Program Files (x86)\Java\jre7\bin\java.exe is the java it auto sets (wont let me change)
and wont let me go past -Xmx2048M -Xmx1024M aka 2gb I tried your thing and it sadly crashed the launcher xD (idk how that worked) but it sadly didn't work :/
By Ilatia211
#148052 I have the same issue too. I have tried to increase the RAM allocation to 2 GB and it just wouldn't go. I have it pointed to the 64 bit java that's used in the new Minecraft launcher. I know I have more than enough ram to handle this.