Forum rules: Do not post bugs or feature requests here! Report bugs to our Issue Tracker and suggestions to Suggest a Feature.

This site is not for solicitation of services or 'purchasing' development. Please do not post requesting side mods/plugins and so on. Your thread will be removed, and you will receive a warning.
By Ninja0719
#11095 I'm new to this so my apologies, have a 6 year old going crazy to get this working. Documentation assumes MC 1.4.7 and a really old 1.4.7 compatible Forge load. I would be willing to use the old loads recommended in the 2.03 download page but it seems MC always gets updated to 1.5.

So, I have MC 1.5 and have loaded Forge universal 1.5-7.7.0.559 (the first for MC 1.5) and 1.5-7.7.0.589 (the latest for MC 1.5) This loads and works just fine. When I then roll in the database and mod folders in the Pixelmon 2.03 download I either get a blank screen, or sometimes a Java error.

I am running this on a Windows 8 desktop but have the same issue on a Windows XP laptop so I'm hoping it's something stupid I am overlooking. To summarize:
1. Load and install MC 1.5 just fine.
2. Load and install Forge 1.5-7.7.0.x just fine. Delete META-INF folder from Minecraft jar both before doing so, and based on other recommendations I found have even done it afterward.
3. Copy the database and mod folders from the Pixelmon 2.03 zip to the main .minecraft folder.

Once I do #2 and test/validate everything is fine (and it shows 3 mods loaded including coder pack 7.42, mod loader 5.0.25.589, forge 7.7.0.589. After #3 I validate the mods folder has only the Pixelmon 2.03 zip file and the database folder has only the SQLite-jdbc-3.7.2.jar and the Pixelmon.db.
Now when launching Minecraft.exe I see some minimal forge stuff, the Mojang banner screen, then black screen. The log shows it going haywire on the command spawn not finding the class. Are the 2.02 and 2.03 truly "patches" or full loads -- i.e. do I have to load these incrementally after getting a prior version working?

2013-03-17 14:56:41 [FINE] [ForgeModLoader] Pixelmon(Pixelmon:2.0.3): Pixelmon 2.0.3.zip ()
2013-03-17 14:56:41 [FINEST] [mcp] Sending event FMLConstructionEvent to mod mcp
2013-03-17 14:56:41 [FINEST] [mcp] Sent event FMLConstructionEvent to mod mcp
2013-03-17 14:56:41 [FINEST] [FML] Sending event FMLConstructionEvent to mod FML
2013-03-17 14:56:41 [FINEST] [FML] Sent event FMLConstructionEvent to mod FML
2013-03-17 14:56:41 [FINEST] [Forge] Sending event FMLConstructionEvent to mod Forge
2013-03-17 14:56:41 [FINEST] [Forge] Sent event FMLConstructionEvent to mod Forge
2013-03-17 14:56:41 [FINEST] [Pixelmon] Sending event FMLConstructionEvent to mod Pixelmon
2013-03-17 14:56:41 [INFO] [STDERR] Exception in thread "Minecraft main thread" java.lang.NoClassDefFoundError: pixelmon/CommandSpawn
2013-03-17 14:56:41 [INFO] [STDERR] at java.lang.Class.forName0(Native Method)
2013-03-17 14:56:41 [INFO] [STDERR] at java.lang.Class.forName(Unknown Source)
2013-03-17 14:56:41 [INFO] [STDERR] at cpw.mods.fml.common.FMLModContainer.constructMod(FMLModContainer.java:446)
2013-03-17 14:56:41 [INFO] [STDERR] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2013-03-17 14:56:41 [INFO] [STDERR] at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
2013-03-17 14:56:41 [INFO] [STDERR] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
2013-03-17 14:56:41 [INFO] [STDERR] at java.lang.reflect.Method.invoke(Unknown Source)
2013-03-17 14:56:41 [INFO] [STDERR] at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
2013-03-17 14:56:41 [INFO] [STDERR] at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
2013-03-17 14:56:41 [INFO] [STDERR] at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
2013-03-17 14:56:41 [INFO] [STDERR] at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
2013-03-17 14:56:41 [INFO] [STDERR] at com.google.common.eventbus.EventBus.post(EventBus.java:267)
2013-03-17 14:56:41 [INFO] [STDERR] at cpw.mods.fml.common.LoadController.propogateStateMessage(LoadController.java:165)
2013-03-17 14:56:41 [INFO] [STDERR] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2013-03-17 14:56:41 [INFO] [STDERR] at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
2013-03-17 14:56:41 [INFO] [STDERR] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
2013-03-17 14:56:41 [INFO] [STDERR] at java.lang.reflect.Method.invoke(Unknown Source)
2013-03-17 14:56:41 [INFO] [STDERR] at com.google.common.eventbus.EventHandler.handleEvent(EventHandler.java:74)
2013-03-17 14:56:41 [INFO] [STDERR] at com.google.common.eventbus.SynchronizedEventHandler.handleEvent(SynchronizedEventHandler.java:45)
2013-03-17 14:56:41 [INFO] [STDERR] at com.google.common.eventbus.EventBus.dispatch(EventBus.java:314)
2013-03-17 14:56:41 [INFO] [STDERR] at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:296)
2013-03-17 14:56:41 [INFO] [STDERR] at com.google.common.eventbus.EventBus.post(EventBus.java:267)
2013-03-17 14:56:41 [INFO] [STDERR] at cpw.mods.fml.common.LoadController.distributeStateMessage(LoadController.java:98)
2013-03-17 14:56:41 [INFO] [STDERR] at cpw.mods.fml.common.Loader.loadMods(Loader.java:494)
2013-03-17 14:56:41 [INFO] [STDERR] at cpw.mods.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:160)
2013-03-17 14:56:41 [INFO] [STDERR] at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:406)
2013-03-17 14:56:41 [INFO] [STDERR] at net.minecraft.client.MinecraftAppletImpl.func_71384_a(SourceFile:56)
2013-03-17 14:56:41 [INFO] [STDERR] at net.minecraft.client.Minecraft.run(Minecraft.java:728)
2013-03-17 14:56:41 [INFO] [STDERR] at java.lang.Thread.run(Unknown Source)
User avatar
By MrMasochism
#11096 You cannot install pixelmon onto a 1.5 minecraft install. There is no way that can work. There are a few ways of keeping an older version of minecraft installed though. I believe some people use MultiMC and some use Minecraft Nostalgia
User avatar
By SPG
#11099 there are many (legal) ways to get a 1.4.7 jar, get a program like magic launcher or multimc and you can get older minecraft versions that way to play the mod
JOIN THE TEAM